package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\w+(\.){,1} [a-zA-Z]\)(( |\,)[a-zA-Z]{,3} [a-zA-Z]\))*`)
var str = `As you can see by reading point a) and b), someone could even use lect. A), B) and Z).
foo a), b), c), d) and e)
bar A) and B) and C)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}