import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\w+(\\.)\\{,1\\} [a-zA-Z]\\)(( |\\,)[a-zA-Z]\\{,3\\} [a-zA-Z]\\))*";
final String string = "As you can see by reading point a) and b), someone could even use lect. A), B) and Z).\n\n"
+ "foo a), b), c), d) and e)\n"
+ "bar A) and B) and C)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}