$re = '/\w+(\.){,1} [a-zA-Z]\)(( |\,)[a-zA-Z]{,3} [a-zA-Z]\))*/m';
$str = 'As you can see by reading point a) and b), someone could even use lect. A), B) and Z).
foo a), b), c), d) and e)
bar A) and B) and C)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);