package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([0-9]{1,3}.[0-9]{1,3}.[0-9]{1,3}.[0-9]{1,3})\s{1}(.*)\s{1,}([A-Z0-9]{2}-[A-Z0-9]{2}-[A-Z0-9]{2}-[A-Z0-9]{2}-[A-Z0-9]{2}-[A-Z0-9]{2}:[A-Z0-9]{2})\s{1}(AHM.*)\s([0-9]{1,3})`)
var str = `192.168.128.203 2C-FF-EE B4-C7-99-73-AE-10:R1 AHM WLAN DIREKSI KRW 702`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}