const regex = /([0-9]{1,3}.[0-9]{1,3}.[0-9]{1,3}.[0-9]{1,3})\s{1}(.*)\s{1,}([A-Z0-9]{2}-[A-Z0-9]{2}-[A-Z0-9]{2}-[A-Z0-9]{2}-[A-Z0-9]{2}-[A-Z0-9]{2}:[A-Z0-9]{2})\s{1}(AHM.*)\s([0-9]{1,3})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([0-9]{1,3}.[0-9]{1,3}.[0-9]{1,3}.[0-9]{1,3})\\s{1}(.*)\\s{1,}([A-Z0-9]{2}-[A-Z0-9]{2}-[A-Z0-9]{2}-[A-Z0-9]{2}-[A-Z0-9]{2}-[A-Z0-9]{2}:[A-Z0-9]{2})\\s{1}(AHM.*)\\s([0-9]{1,3})', 'gm')
const str = `192.168.128.203 2C-FF-EE B4-C7-99-73-AE-10:R1 AHM WLAN DIREKSI KRW 702`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}