re = /([0-9]{1,3}.[0-9]{1,3}.[0-9]{1,3}.[0-9]{1,3})\s{1}(.*)\s{1,}([A-Z0-9]{2}-[A-Z0-9]{2}-[A-Z0-9]{2}-[A-Z0-9]{2}-[A-Z0-9]{2}-[A-Z0-9]{2}:[A-Z0-9]{2})\s{1}(AHM.*)\s([0-9]{1,3})/m
str = '192.168.128.203 2C-FF-EE B4-C7-99-73-AE-10:R1 AHM WLAN DIREKSI KRW 702'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end