# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"8[^\d]*+8[^\d]*+8[^\d]*+9[^\d]*+5[^\d]*+9[^\d]*+2(?:[^\d]|0)*+1[^\d]*+1"
test_str = ("-888x(959)x2O11\n"
"88 8~(959) <2O><11> \n"
"8889592011\n"
"8;?889592011\n"
"888 ^9 <5> 9 2 <O>11\n"
"8abc8[8];',. 9 **5 92011\n")
matches = re.finditer(regex, test_str, re.MULTILINE | re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.