// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)8[^\d]*+8[^\d]*+8[^\d]*+9[^\d]*+5[^\d]*+9[^\d]*+2(?:[^\d]|0)*+1[^\d]*+1").unwrap();
let string = "-888x(959)x2O11
88 8~(959) <2O><11>
8889592011
8;?889592011
888 ^9 <5> 9 2 <O>11
8abc8[8];',. 9 **5 92011
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}