#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\*1\*(.*?)\*11\*(.*?)\*(?:(?!IGNORE).)*?\*53\*(.*?)##"
Local $sString = "*1*20*11*30*IGNORE*53*40##" & @CRLF & _
"" & @CRLF & _
"*1*20*11*30*some*53*40##"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")