import re
regex = re.compile(r"\*1\*(.*?)\*11\*(.*?)\*(?:(?!IGNORE).)*?\*53\*(.*?)##")
test_str = ("*1*20*11*30*IGNORE*53*40##\n\n"
"*1*20*11*30*some*53*40##")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")