use strict;
my $str = '*1*20*11*30*IGNORE*53*40##
*1*20*11*30*some*53*40##';
my $regex = qr/\*1\*(.*?)\*11\*(.*?)\*(?!IGNORE\*)(.*?)\*53\*(.*?)##/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}