re = /\*1\*(.*?)\*11\*(.*?)\*(?!IGNORE\*)(.*?)\*53\*(.*?)##/
str = '*1*20*11*30*IGNORE*53*40##
*1*20*11*30*some*53*40##'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end