$re = '/\*1\*(.*?)\*11\*(.*?)\*(?!IGNORE\*)(.*?)\*53\*(.*?)##/';
$str = '*1*20*11*30*IGNORE*53*40##
*1*20*11*30*some*53*40##';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);