import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Account For Which Logon Failed.* Account Name:.+?\\b(.*?)\\s";
final String string = " An account failed to log on.\n\n"
+ " Subject:\n"
+ " Security ID: S-1-5-21-1287344763-2688370722-3395302928-19873\n"
+ " Account Name: service_adfs\n"
+ " Account Domain: DOMAIN\n"
+ " Logon ID: 0xD62E4\n\n"
+ " Logon Type: 3\n\n"
+ " Account For Which Logon Failed:\n"
+ " Security ID: S-1-0-0\n"
+ " Account Name: user.thatiwant@DOMAIN.com\n"
+ " Account Domain: ";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}