re = /Account For Which Logon Failed.* Account Name:.+?\b(.*?)\s/
str = ' An account failed to log on.
Subject:
Security ID: S-1-5-21-1287344763-2688370722-3395302928-19873
Account Name: service_adfs
Account Domain: DOMAIN
Logon ID: 0xD62E4
Logon Type: 3
Account For Which Logon Failed:
Security ID: S-1-0-0
Account Name: user.thatiwant@DOMAIN.com
Account Domain: '
# Print the match result
str.match(re) do |match|
puts match.to_s
end