import re
regex = re.compile(r"Account For Which Logon Failed.* Account Name:.+?\b(.*?)\s", flags=re.DOTALL)
test_str = (" An account failed to log on.\n\n"
" Subject:\n"
" Security ID: S-1-5-21-1287344763-2688370722-3395302928-19873\n"
" Account Name: service_adfs\n"
" Account Domain: DOMAIN\n"
" Logon ID: 0xD62E4\n\n"
" Logon Type: 3\n\n"
" Account For Which Logon Failed:\n"
" Security ID: S-1-0-0\n"
" Account Name: user.thatiwant@DOMAIN.com\n"
" Account Domain: ")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")