const regex = new RegExp('^/(?<page>quizzes)(?:/(?<subpage>[\\w-]+)?)?(?:\\.xml)$', 'gm')
const str = `# EXPECTED URL MATCHES
/quizzes
/quizzes/
/quizzes/food
/quizzes/food/
/quizzes.xml
/quizzes/food.xml
# EXPECTED URL NON-MATCHES
/quizzes2
/quizzes.xml/
/quizzes/food.xml/
/investigations
/investigations/foo
/jobs/something
/foo/bar
/jp/index
/about
/press
/uk/shopping
/esp/shopping
/shopping
/jp/shopping
/jp/quizzes
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}