use strict;
my $str = '# EXPECTED URL MATCHES
/quizzes
/quizzes/
/quizzes/food
/quizzes/food/
/quizzes.xml
/quizzes/food.xml
# EXPECTED URL NON-MATCHES
/quizzes2
/quizzes.xml/
/quizzes/food.xml/
/investigations
/investigations/foo
/jobs/something
/foo/bar
/jp/index
/about
/press
/uk/shopping
/esp/shopping
/shopping
/jp/shopping
/jp/quizzes
';
my $regex = qr~^/(?<page>quizzes)(?:/(?<subpage>[\w-]+)?)?(?:\.xml)$~mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}