import re
regex = re.compile(r"^/(?<page>quizzes)(?:/(?<subpage>[\w-]+)?)?(?:\.xml)$", flags=re.MULTILINE)
test_str = ("# EXPECTED URL MATCHES\n\n"
"/quizzes\n"
"/quizzes/\n"
"/quizzes/food\n"
"/quizzes/food/\n"
"/quizzes.xml\n"
"/quizzes/food.xml\n\n\n"
"# EXPECTED URL NON-MATCHES\n\n"
"/quizzes2\n"
"/quizzes.xml/\n"
"/quizzes/food.xml/\n"
"/investigations\n"
"/investigations/foo\n"
"/jobs/something\n"
"/foo/bar\n"
"/jp/index\n"
"/about\n"
"/press\n"
"/uk/shopping\n"
"/esp/shopping\n"
"/shopping\n"
"/jp/shopping\n"
"/jp/quizzes\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")