import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[([biu])]([\\s\\S]+?)\\[\\/\\1]";
final String string = "[b]Bold[/b]\n"
+ "[i]Italic[/i]\n"
+ "[u]Under\n"
+ "line[/u]\n\n"
+ "[b]Bold [i]Italic[/i][/b]\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}