$re = '/\[([biu])]([\s\S]+?)\[\/\1]/';
$str = '[b]Bold[/b]
[i]Italic[/i]
[u]Under
line[/u]
[b]Bold [i]Italic[/i][/b]
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);