re = /\[([biu])]([\s\S]+?)\[\/\1]/
str = '[b]Bold[/b]
[i]Italic[/i]
[u]Under
line[/u]
[b]Bold [i]Italic[/i][/b]
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end