#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!foo$)"
Local $sString = "Not:" & @CRLF & _
"foo" & @CRLF & _
"But:" & @CRLF & _
"Text with foo hereee" & @CRLF & _
"" & @CRLF & _
"foo Text " & @CRLF & _
"" & @CRLF & _
"More foo" & @CRLF & _
"foo " & @CRLF & _
" ^ whitespace ^" & @CRLF & _
"1" & @CRLF & _
"12" & @CRLF & _
"Match this line" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")