$re = '/^(?!foo$)/m';
$str = 'Not:
foo
But:
Text with foo hereee
foo Text
More foo
foo
^ whitespace ^
1
12
Match this line
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);