import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!foo$)";
final String string = "Not:\n"
+ "foo\n"
+ "But:\n"
+ "Text with foo hereee\n\n"
+ "foo Text \n\n"
+ "More foo\n"
+ "foo \n"
+ " ^ whitespace ^\n"
+ "1\n"
+ "12\n"
+ "Match this line\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}