package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[^\n|]*$`)
var str = `
Text
Name|Value
And this |
Match this |
Match this line`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}