$re = '/^[^\n|]*$/m';
$str = '
Text
Name|Value
And this |
Match this |
Match this line';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);