re = /^[^\n|]*$/m
str = '
Text
Name|Value
And this |
Match this |
Match this line'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end