#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\/cue\/(?<Name>(?:LIGHT|PAR|EFFECT|EFFECT_S|VIDEO))\/((?<Group>([0-9oe,-]+|(?:ALL)))\/(?<Point>([0-9oe,-]+|(?:ALL)))\/(?<Brightness>([0-9,]+))\/(?<Time>([0-9]+))\/$|(?<PointP>([0-9oe,-]+|(?:ALL)))\/(?<BrightnessP>([0-9,]+))\/(?<TimeP>([0-9]+))\/$|(?<EffectName>(?:VIDEO|CUE|LIGHT_BALL|RAIN|SATURN_RING))\/((?<Weight>[0-9\-.]+)|(?<Parameters>([a-zA-Z0-9\-,{}=.;]+)))\/|(?<Contant>([a-zA-Z0-9\-\/._]+))\/)"
Local $sString = "/cue/LIGHT/10/10/255/0/" & @CRLF & _
"/cue/PAR/10/255/0/" & @CRLF & _
"" & @CRLF & _
"/cue/EFFECT/VIDEO/1.8/" & @CRLF & _
"/cue/EFFECT_S/RAIN/{1,2,3,4,5,}/" & @CRLF & _
"" & @CRLF & _
"/cue/VIDEO/PLAY/" & @CRLF & _
"/cue/VIDEO/TIME/0.5/" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")