$re = '/\/cue\/(?<Name>(?:LIGHT|PAR|EFFECT|EFFECT_S|VIDEO))\/((?<Group>([0-9oe,-]+|(?:ALL)))\/(?<Point>([0-9oe,-]+|(?:ALL)))\/(?<Brightness>([0-9,]+))\/(?<Time>([0-9]+))\/$|(?<PointP>([0-9oe,-]+|(?:ALL)))\/(?<BrightnessP>([0-9,]+))\/(?<TimeP>([0-9]+))\/$|(?<EffectName>(?:VIDEO|CUE|LIGHT_BALL|RAIN|SATURN_RING))\/((?<Weight>[0-9\-.]+)|(?<Parameters>([a-zA-Z0-9\-,{}=.;]+)))\/|(?<Contant>([a-zA-Z0-9\-\/._]+))\/)/m';
$str = '/cue/LIGHT/10/10/255/0/
/cue/PAR/10/255/0/
/cue/EFFECT/VIDEO/1.8/
/cue/EFFECT_S/RAIN/{1,2,3,4,5,}/
/cue/VIDEO/PLAY/
/cue/VIDEO/TIME/0.5/
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);