using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\d\d[.]\d\d[.]\d\d.\d\d[:]\d\d:\d\d";
string input = @"до 14.09.20 23:59:59 (МСК)";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}