package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\d\d[.]\d\d[.]\d\d.\d\d[:]\d\d:\d\d`)
var str = `до 14.09.20 23:59:59 (МСК)`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}