$re = '/\d\d[.]\d\d[.]\d\d.\d\d[:]\d\d:\d\d/';
$str = 'до 14.09.20 23:59:59 (МСК)';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);