package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s)(^\/\*\*(.*?)\*\*\/)`)
var str = `/**
HI
**/
#define 1
/** Hi **/
/** Hi **/
`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}