$re = '/(^\/\*\*(.*?)\*\*\/)/s';
$str = '/**
HI
**/
#define 1
/** Hi **/
/** Hi **/
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);