package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^\$2y\$.{56}$`)
var str = `$2y$15$nK/B6u765645/lo0867h56546v/BnH5U5g45Aj67u67nMVtrhryt6`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}