re = /^\$2y\$.{56}$/
str = '$2y$15$nK/B6u765645/lo0867h56546v/BnH5U5g45Aj67u67nMVtrhryt6'
# Print the match result
str.match(re) do |match|
puts match.to_s
end