const regex = /^\$2y\$.{56}$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\$2y\\$.{56}$', '')
const str = `\$2y\$15\$nK/B6u765645/lo0867h56546v/BnH5U5g45Aj67u67nMVtrhryt6`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}