using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([^#\r\n]+?)[^\S\r\n]*#";
string input = @"These are words before hashtag #work/abc/xyz/123
These are words before hashtag #work/abc/xyz/123
These are words before hashtag #work/abc/xyz/123
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}