re = /^([^#\r\n]+?)[^\S\r\n]*#/m
str = 'These are words before hashtag #work/abc/xyz/123
These are words before hashtag #work/abc/xyz/123
These are words before hashtag #work/abc/xyz/123
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end