import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((0?[1-9]|[12][0-9]|3[01])\\/(0?[1-9]|1[012])\\/([0-9]{4})(\\s([01][0-9]|2[0-4]):([0-5][0-9]):([0-5][0-9]))?(.([0-9]{3,6}))?)";
final String string = "12/07/1994 12:12:12.620000";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}