const regex = /((0?[1-9]|[12][0-9]|3[01])\/(0?[1-9]|1[012])\/([0-9]{4})(\s([01][0-9]|2[0-4]):([0-5][0-9]):([0-5][0-9]))?(.([0-9]{3,6}))?)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((0?[1-9]|[12][0-9]|3[01])\\\/(0?[1-9]|1[012])\\\/([0-9]{4})(\\s([01][0-9]|2[0-4]):([0-5][0-9]):([0-5][0-9]))?(.([0-9]{3,6}))?)', '')
const str = `12/07/1994 12:12:12.620000`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}