$re = '/((0?[1-9]|[12][0-9]|3[01])\/(0?[1-9]|1[012])\/([0-9]{4})(\s([01][0-9]|2[0-4]):([0-5][0-9]):([0-5][0-9]))?(.([0-9]{3,6}))?)/';
$str = '12/07/1994 12:12:12.620000';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);