package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(1|2)\d{3}\-(0[1-9]|1[0-2])\-((0[1-9])|((1|2)\d)|3(0|1))(T|\s)((0|1)\d|2[0-3]):([0-5]\d):([0-5]\d)((\+0\d|\+1[0-4]|-0\d|-1[0-2])([0-5]d)?)?|(\d{10-13})`)
var str = `2018-05-25 23:59:59`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}