// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^(1|2)\d{3}\-(0[1-9]|1[0-2])\-((0[1-9])|((1|2)\d)|3(0|1))(T|\s)((0|1)\d|2[0-3]):([0-5]\d):([0-5]\d)((\+0\d|\+1[0-4]|-0\d|-1[0-2])([0-5]d)?)?|(\d{10-13})").unwrap();
let string = "2018-05-25 23:59:59";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}