import Foundation
let pattern = #"^(1|2)\d{3}\-(0[1-9]|1[0-2])\-((0[1-9])|((1|2)\d)|3(0|1))(T|\s)((0|1)\d|2[0-3]):([0-5]\d):([0-5]\d)((\+0\d|\+1[0-4]|-0\d|-1[0-2])([0-5]d)?)?|(\d{10-13})"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"2018-05-25 23:59:59"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)