package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:START)?(\w+)\(([^)]*)\)`)
var str = `START1(stuff); II(morestuff); 8(lessstuff)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}