re = /(?:START)?(\w+)\(([^)]*)\)/m
str = 'START1(stuff); II(morestuff); 8(lessstuff)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end