$re = '/(?:START)?(\w+)\(([^)]*)\)/m';
$str = 'START1(stuff); II(morestuff); 8(lessstuff)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);