import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[\\[(.*)\\]\\] \\((.*)\\)";
final String string = "__NOTOC__\n\n"
+ "{{SubTOC|Titel=Liste von Autoren|Index=Liste von Autoren}}\n\n"
+ "== Aa ==\n"
+ ": [[Bertus Aafjes]] (1914–1993), NL : [[Jeppe Aakjær]] (1866–1930), DK\n"
+ ": [[Johannes Aal]] (um 1500–1551), CH : [[Hans Aanrud]] (1863–1953), NO\n"
+ ": [[Emil Aarestrup]] (1800–1856), DK : [[Soazig Aaron]] (* 1949), FR: [[Ivar Aasen]] (1813–1896), NO\n\n"
+ "== Ab ==\n"
+ ": [[Petrus Abaelardus]] (1079–1142), FR : [[Sait Faik Abasıyanık]] (1906–1954), TR\n"
+ ": [[Lynn Abbey]] (* 1948), US : [[Jacob Abbott]] (1803–1879), US\n"
+ ": [[John Stevens Cabot Abbott]] (1805–1877), US : [[Abdullah bin Abdul Kadir]] (1795–1852), MAL\n"
+ ": [[Abe Kōbō]] (1924–1993), JP : [[Rebecca \n"
+ "Abe]] (* \n"
+ "1967), D ";
final Pattern pattern = Pattern.compile(regex, Pattern.UNICODE_CHARACTER_CLASS | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}